Relay Incident
Incident Report for Mozilla Services
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 19:35 UTC
Investigating
We are currently investigating an issue with Relay.
Posted Mar 28, 2024 - 16:13 UTC
This incident affected: Relay (https://relay.firefox.com/).