Phone Calls and Text Messages Not Working
Incident Report for Mozilla Services
Resolved
This incident has been resolved.
Posted Jan 02, 2025 - 20:26 UTC
Investigating
We are currently experiencing issues affecting the following services:

Receiving phone calls
Receiving text messages
Replying to text messages

Our team is actively investigating the issue to restore these services as quickly as possible. We apologize for any inconvenience and appreciate your patience.

Please check back here for updates.
Posted Jan 02, 2025 - 16:42 UTC
This incident affected: Relay (https://relay.firefox.com/).